Utenti collegati: 38 
 
it.comp.lang.javascript
Il linguaggio JavaScript

Indice messaggi | Invia un reply | Tutti i newsgroup | Cerca | Statistiche 



  Inviato da: King Lion  Mostra tutti i messaggi di King Lion
Titolo: Utilizzo di un file JS con webserver Arduino
Newsgroup: it.comp.lang.javascript
Data: 13/05/2017
Ora: 20:35:52
Mostra headers
 
  Salve,<br /> <br /> sto lavorando su un progettino con una scheda ESP8266 programmata per funzionare da webserver.<br /> <br /> Quando questo webserver viene contattato dal browser, invia al browser il codice seguente:<br /> <br /> HTTP/1.1 200 OK\r\nContent-Type: text/html\r\n\r\n&lt;!DOCTYPE HTML&gt;\r\n<br /> &lt;html&gt;&lt;head&gt;<br /> &lt;/head&gt;&lt;body&gt;<br /> &lt;script type='text/javascript' src='http://www.squix.org<br /> /blog/smartcar.js'&gt;&lt;/script&gt;<br /> &lt;a href='#' onclick='move(\&quot;f\&quot;);'&gt;forward&lt;/a&gt;&lt;BR/&gt;<br /> &lt;a href='#' onclick='move(\&quot;b\&quot;);'&gt;backwards&lt;/a&gt;&lt;BR/&gt;<br /> &lt;a href='#' onclick='move(\&quot;l\&quot;);'&gt;left&lt;/a&gt;&lt;BR/&gt;<br /> &lt;a href='#' onclick='move(\&quot;r\&quot;);'&gt;right&lt;/a&gt;&lt;BR/&gt;<br /> &lt;div id=\&quot;dmEvent\&quot;/&gt;<br /> &lt;div id=\&quot;vector\&quot;/&gt;<br /> &lt;/body&gt;&lt;/html&gt;<br /> <br /> Sul browser vengono visualizzati 4 scritte cliccabili: forward backwards left right.<br /> <br /> E fino a qui tutto bene.<br /> <br /> Adesso quando si clicca sopra una delle scritte, dovrebbe venire eseguito il codice smartcar.js il quale, alla fine, dovrebbe inviare al webserver una richiesta del tipo indirizzo_ip/engines/[nnn][nnn]<br /> <br /> dove nnn tra le parentesi quadre sono due numeri che vanno da 0 (=motore fermo) al numero massimo (=velocita' massima motore) uno per il motore destro e uno per il motore sinistro.<br /> <br /> Questi numeri partono da 0 e si incrementano con il parametro accelerazione inserito nel codice js fino al massimo.<br /> <br /> Ebbene: a me non funziona :(<br /> <br /> Quello che viene inviato al serverweb dal browser e' un testo del tipo indirizzo_ip/# e basta.<br /> <br /> Cosa c'e' di sbagliato secondo voi? Ed eventualmente come posso fare per capire il problema visto che sono piuttosto digiuno di html e js?<br /> <br /> Il browser e' Firefox ed ho provato sia su Windows che su OSX<br /> <br /> Grazie per eventuali aiuti<br /> Saluti<br /> Giuseppe<br /> <br /> <br /> <br />  

Il thread:
da leggere King Lion 13/05 20:35
Utilizzo di un file JS con webserver Arduino
   da leggere fmigliori@gmail.com 15/05 21:08
Re: Utilizzo di un file JS con webserver Arduino
      da leggere Giuseppe³ 20/05 17:25
Re: Utilizzo di un file JS con webserver Arduino
 

Invia una risposta:

Nome:

Email:

Titolo:

Testo:


Attenzione: l'invio del messaggio richiede diversi secondi.
Non premere pi� volte il tasto "Invia".

 © Sergio Simonetti 2001 Che cos'è Links