Utenti collegati: 18 
 
it.comp.retrocomputing
Macchine che hanno fatto la storia informatica

Indice messaggi | Invia un reply | Tutti i newsgroup | Cerca | Statistiche 



  Inviato da: Claudio Di Cesare  Mostra tutti i messaggi di Claudio Di Cesare
Titolo: [Lungo] Riparazione Texas Instruments Travelmate 2000
Newsgroup: it.comp.retrocomputing
Data: 27/10/2017
Ora: 12:14:38
Mostra headers
 
  Salve,<br /> ho da circa 20 anni questo portatilino riposto con cura in una scatola.<br /> Era di un collega che quando me lo diede disse che improvvisamente si era s=<br /> pento e mai pi=C3=B9 ripartito, per fortuna aveva un backup, visto che cont=<br /> enva il codice di un programma in fase di realizzazione :-).<br /> <br /> Per la cronaca parliamo di un 286 a 12Mhz con 1Mb di ram e disco da 20Mb. D=<br /> os 4.0 e Laplink in ROM e Windows 3.0.<br /> La particolarit=C3=A0 =C3=A8 che monta delle porte non standard per il keyp=<br /> ad numerico e la parallela, mentre per fortuna ha una DB9 standard per la s=<br /> eriale.<br /> All'interno era disponibile uno slot per un fax/modem e due slot proprietar=<br /> i per 2 espansioni ram da 1Mb.<br /> Il progetto (e la manifattura) erano opera della Sharp, dentro a parte qual=<br /> che chip Texas =C3=A8 tutta roba Sharp.<br /> Il processore =C3=A8 della Harris su licenza Intel e lo zoccolo del coproce=<br /> ssore matematico =C3=A8 libero e ci va un 10Mhz (se qualcuno ce l'ha).<br /> <br /> Torniamo al &quot;cadavere&quot;...<br /> Quando lo ricevetti ho provveduto a controllare le tensioni in uscita (con =<br /> carico di un paio di resistense da un paio di watt) dell'alimentatore. Tutt=<br /> o regolare.<br /> A quel punto cominciai a smontarlo. Rimosso il pacco batterie NiCd (meno ma=<br /> le, adesso =C3=A8 tutto ricoperto di verde rame!). Rimosso LCD.<br /> Mi sono concentrato sull'alimentatore, alla ricerca di qualche evidente seg=<br /> no di &quot;fumata&quot;... nulla.<br /> Questo =C3=A8 composto da due schede montate &quot;a panino&quot; che si collegano al=<br /> la scheda madre con due connettori, uno multifili (marrone, giallo e rosso)=<br /> ed una piattina.<br /> Due foto delle schede:<br /> http://i65.tinypic.com/25834aq.jpg<br /> http://i66.tinypic.com/zvppp0.jpg<br /> <br /> I condensatori sembrano buoni, sono molto piccoli, non ho sostituti di quel=<br /> l'altezza...<br /> Alimentando con l'alimentatore da laboratorio, mostra un assorbimento di 0.=<br /> 02A (troppo poco per un portatile 286 di 20 anni fa).<br /> La cosa strana =C3=A8 che inserendo lentamente lo spinotto alcune volte il =<br /> portatile sembra partire (si accendono i led di stato e addirittura parte l=<br /> 'HD), in questo caso l'assorbimento sale a circa 0.50-060 A (compatibile co=<br /> n un'alimentazione attiva).<br /> Una sola volta ho trovato una posizione in cui si =C3=A8 acceso, ha fatto l=<br /> a sequenza di accensione e spegnimento dei led di stato, =C3=A8 partito l'h=<br /> ard disk e poi il classico &quot;beep, beep&quot; di errore bios (probabilmente la me=<br /> moria tampone che non ha dati congrui).<br /> Inutile dire che spostando di poco lo spinotto non si =C3=A8 riacceso pi=C3=<br /> =B9...<br /> <br /> La prima cosa che ho fatto =C3=A8 stato &quot;ripassare&quot; un po' di saldature... =<br /> niente.<br /> Poi ho provveduto a sostituire lo spinotto femmina sulla scheda... niente.<br /> Poi ho sostituito l'interruttore di accensione (un piccolo a bilanciere)...=<br /> niente.<br /> I 3 fusibili (cilindretti neri) sembrano ok d'altronde, lo ripeto, una volt=<br /> a =C3=A8 partito...<br /> La mia diagnosi =C3=A8 che la parte semiconduttori dovrebbe essere OK, da c=<br /> ui le accensioni riuscite, forse =C3=A8 qualcosa nei componenti discreti ch=<br /> e ha problemi &quot;all'avvio&quot;.<br /> Lo so, i piu' papabili sono gli elettrolitici, mi sto attivando per reperir=<br /> e un po' di materiale &quot;compatibile&quot;. Il problema dell'altezza, non =C3=A8 b=<br /> anale, perch=C3=A8 come ho spiegato, le due schede sono poi montate una sul=<br /> l'altra e i condensatori (ovviamente) sono su quella di sotto! :-)<br /> <br /> Finito questo lungo post, se avete avuto la voglia di leggerlo, vi chiedo d=<br /> i condividere qualche consiglio, magari mi riesce di riattivarlo.<br /> Grazie, a presto.<br /> <br /> Claudio  

Il thread:
da leggere Claudio Di Cesare 27/10 12:14
[Lungo] Riparazione Texas Instruments Travelmate 2000
   da leggere TelespallaBob 27/10 14:39
Re: [Lungo] Riparazione Texas Instruments Travelmate 2000
      da leggere Claudio Di Cesare 28/10 18:09
Re: [Lungo] Riparazione Texas Instruments Travelmate 2000
 

Invia una risposta:

Nome:

Email:

Titolo:

Testo:


Attenzione: l'invio del messaggio richiede diversi secondi.
Non premere pi� volte il tasto "Invia".

 © Sergio Simonetti 2001 Che cos'è Links